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Note: This discussion is based on MacOS, 10.12.5 (Sierra). Some illustrations may differ when using 
other versions of macOS or OS X.  
Credit 1: Activity Monitor Help 
Credit 2:  Use Activity Monitor on your Mac (https://support.apple.com/en-us/HT201464) 
Credit 3: How to Use macOS’ Activity Monitor Like a Power User 
(http://www.applegazette.com/mac/macos-activity-monitor-like-power-user/) 
Credit 4: Activity Monitor Demystified  
(https://computers.tutsplus.com/tutorials/activity-monitor-demystified--mac-30611)  
Credit 5: Using Activity Monitor (https://macmost.com/using-activity-monitor.html)  

Over the next few presentations, I’m going to review several macOS utility apps that 
you may find useful. Activity Monitor is the topic this month along with the first 
three of its monitoring functions: CPU, Memory, and Energy. Next month, we’ll review 
the Disk and Network functions, some additional information, and discuss using 
Activity Monitor to troubleshoot performance problems.  

Activity Monitor is found in the Utilities folder inside the Applications folder  
(Finder > Applications folder > Utilities folder).  Alternative: Finder > Go menu > 
Utilities menu item. Of course, you can also search for it with Spotlight.  

 
Activity Monitor Icon 

The app name, Activity Monitor, describes exactly what it does: it monitors the 
activity on your Mac, keeping track of the system resources that Mac apps are using.  

The information provided by Activity Monitor can be valuable in troubleshooting, 
such as finding an app that’s slowing down your Mac’s responsiveness. In a pinch, 
you can even use it to force quit an app.  

Main Window 
Activity Monitor’s main window default view (illustration on the next page) provides 
a table of all the currently running applications and information about them such as 
the percentage of CPU capacity that each one is using. It also shows all the 
processes running on your Mac. Processes can be your user apps, system apps 
used by macOS, and daemons. (Daemons are invisible processes or programs that 
run in the background to handle requests for services, such as print spooling and 
file transfers, and is dormant when not required.) You’ll find that your Mac runs a 
lot of processes. I found almost 400 of them running on my iMac.  

Computer operating systems are complex, and most of what’s displayed by  
Activity Monitor probably won’t be of much use to you (unless you’re a developer, 
programmer or software engineer) and can be ignored. Because Activity Monitor 
provides a great deal of information, it’s easy to become overwhelmed with all 
these processes and what each one does. So, don’t let yourself get mired down in 
all the technical details.  
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Activity Monitor does have several useful items for the majority of users, and you 
can use the View menu to help select them. (More on this later.)  

 
 Activity Monitor Window (CPU Pane) (Credit: Apple Support – Use Activity Monitor on your Mac) 

At the bottom of the window pane for each tab (see below), is some high level 
summary data. This information can be useful to quickly see how much of your 
system is currently being used. The summary changes as you click on different tabs. 

 
 Activity Monitor Window – Summary Information (Credit: Apple Support – Use Activity Monitor on your Mac) 

For example, in the pane for the CPU tab above, there’s a table showing the 
percentage of CPU capacity (load) that system and user processes are using, along 
with a graph showing the same data. There’s also a table of Threads and Processes.  
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Category Panes 
As you can see below, there are five category resource tabs at the top of the 
Activity Monitor window.  

Each one changes the window view (pane) to show a different category of 
resources being monitored: CPU (shown in the illustration), Memory, Energy, Disk 
and Network. These provide information about a particular set of resources, and 
how much of it an app or other process is using.  

 
 Activity Monitor Window (CPU Category Pane) – Summary Information  
(Credit: Apple Support – Use Activity Monitor on your Mac) 

As you click on each category tab, the window’s contents change to show you a 
different set of resources and how much of a given resource all running processes 
are using.  

The window display for each tab shows different columns of information. Each of 
these corresponds to a different attribute (characteristic) of the Process being 
examined.  

Note: Depending on how your Activity Monitor has been configured, the display of 
resources may differ from those shown in this presentation.  

The Process Name column (App Name in the Energy tab) is common to all the tabs. 
Click on a column header to change the sort order. The User column is also 
frequently present as well.  

View Menu  
You can add or remove columns in each of these panes by choosing Columns from 
the View menu the menu bar. (See the illustration on the next page.) 

As you can see, the View menu offers a lot of viewing configuration options to 
control what is displayed in each pane: 
• Columns  
• Dock Icon (CPU Usage, CPU History, Network Usage, Disk Activity, Application Icon) 
• Update Frequency (Very often/1 sec, Often/2 sec, Normal/5 sec) 
• Processes 



June 25, 2017, Beginners SIG 
Activity Monitor (Part 1 of 2) 

Page 4 of 12 

 
 Activity Monitor – View Menu 

The View menu allows you to choose which processes are shown in each pane: 
• All Processes 
• All Processes Hierarchically: Processes that belong to other processes, so you 

can see the parent/child relationship between them. 
• My Processes: Processes owned by your macOS user account. 
• System Processes: Processes owned by macOS. 
• Other User Processes: Processes not owned by the root user or current user. 
• Active Processes: Running processes that aren’t sleeping. 
• Inactive Processes: Running processes that are sleeping. 
• Windowed Processes: Processes that can create a window (usually apps). 
• Selected Processes: Processes that you selected in the Activity Monitor window. 
• Applications in the last 8 hours: Apps that were running processes in the last  

8 hours. 
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CPU Pane 
The CPU pane (see below) shows the processes that are affecting CPU (processor) 
activity. This pane is one of the three most important ones (CPU, Memory and 
Energy panes being the others) and will be discussed in more detail.  

CPU information and the information in the Memory and Energy panes can help 
identify processes that are affecting the performance of your Mac, as well as battery 
runtime, temperature, and fan activity.  

 
 CPU Pane (Credit: Apple Support – Use Activity Monitor on your Mac) 

Display. As shown in the illustration above, the CPU pane displays seven columns: 
Process Name, % CPU, CPU Time, Threads, Idle Wake Ups, PID, and User.  

The most useful of these attributes are: % CPU, CPU Time, and User. Click a 
column header to sort the data (for example: the percentage of CPU capability 
used by each process). 
• % CPU: How much of the Mac’s CPU (Central Processing Unit) is being used by a 

given process.  
• CPU Time: How long a particular process has been actively using the CPU while 

it's been running.  
• User: Which Mac “user” has been using the process. There will always be at 
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least one user (you), and several other “users,” such as root, which are other 
processes that use resources. (User is present in most panes.)  

• Note: Preventing Sleep: This column will likely be present for portable Macs, and 
it’s just what it says. This process is preventing your Mac from going to sleep 
(yes or no).  

Just to be complete, the others are: 
• Threads: A Thread is the smallest set of instructions that can be managed by a 

Process.  
• Idle Wake Ups: Number of times a thread caused the system to wake up from 

an idle state to begin executing the thread.  
• PID: Process Identification Number (Process ID) 

Summary Information. As discussed previously, there’s more information available 
at the bottom of the CPU pane. This is the best place for an overall understanding 
about CPU performance.  

 
 CPU Pane (Summary Information) (Credit: Apple Support – Use Activity Monitor on your Mac) 

• System: The percentage of CPU capability currently used by system processes 
(those that belong to macOS).  

• User: The percentage of CPU capability currently used by apps opened by you or 
by the processes those apps opened.  

• Idle: The percentage of CPU capability not being used. 
• CPU Load: The percentage of CPU capability currently used by all System and 

User processes.  
! The graph moves from right to left. It updates according to the intervals set 

by the Update Frequency menu item in the View menu (View > Update 
Frequency). This setting is the same for all Activity Monitor window panes.  

! The blue color shows the percentage of total CPU capability currently used by 
user processes.  

! The red color shows the percentage of total CPU capability currently used by 
system processes. 

• Threads: The total number of threads used by all processes combined. 
• Processes: The total number of processes currently running. 

Current CPU Usage Display. If you’re particularly interested in current CPU usage, 
you can display it in a separate window or in the Dock:  
• To open a window showing current CPU activity, choose CPU Usage from the 

Window menu (Window > CPU Usage). Keyboard Shortcut: Command-2. (See 
the illustration on the next page.)  
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 Window Menu > CPU Usage  CPU Usage Window (i7 Processor With 8 Cores) 

• Show a graph of this information in your Dock by changing Activity Monitor’s 
Dock icon for to one that shows CPU Usage instead. Choose Dock Icon from the 
View menu and then select the Show CPU Usage sub-menu (View > Dock Icon > 
Show CPU Usage).  

  
 View Menu > Dock Icon > Show CPU Usage  Dock Icon 

Recent CPU Usage Display. Similar to current CPU usage, you can display recent 
CPU usage in a separate window or in the Dock. You can also show a graph of this 
information in your Dock by changing the Dock icon for Activity Monitor to one that 
shows CPU History instead.  
• To open a window showing recent CPU activity, choose CPU History from the 

Window menu (Window > CPU History). Keyboard Shortcut: Command-3.  

  
 Window Menu > CPU History  CPU History Window (i7 Processor With 8 Cores)   

• Show a graph of this information in your Dock by changing the Dock icon for 
Activity Monitor to one that shows CPU History instead. Choose Dock Icon from 
the View menu and then select the Show CPU History sub-menu (View > Dock 
Icon > Show CPU History).  

  
 View Menu > Dock Icon > Show CPU History  Dock Icon 
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Memory Pane 
For information about how memory (RAM) is being used, choose the Memory pane: 

 
 Memory Pane (Credit: Apple Support – Use Activity Monitor on your Mac) 

Display. As shown in the illustration above, the Memory pane displays five 
information columns (excluding Process Name and User): Memory, Compressed 
Mem, Threads, Ports, and PID. The most useful of these are Memory and 
Compressed Mem: 
• Memory: Memory that’s actively being used by a process, such an a app.  
• Compressed Mem: As free memory is used up, macOS starts looking for inactive 

memory (memory that isn't currently in active use but still holds data that will 
be used by an app) to compress and take up less space.  

Summary Information. More information is available at the bottom of the Memory 
pane, providing a nice overview of memory usage:  

 
Memory Pane (Summary Information) (Credit: Mac Activity Help) 
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• Memory Pressure: The Memory Pressure graph helps illustrate the availability of 
memory resources. The graph moves from right to left and updates at the 
intervals set in View > Update Frequency. The current state of memory 
resources is indicated by the color at the right side of the graph:  
! Green: Memory resources are available.  
! Yellow: Memory resources are still available but are being tasked/stressed by 

memory-management processes, such as compression. 
! Red: Memory resources are depleted, and macOS is using your startup drive 

(often a much slower hard disk drive) for memory by being “paged out” 
(temporarily stored) to the drive. To make more RAM available, you can quit 
one or more apps or install more RAM.  
Memory Pressure in the Red is the most important indicator that your Mac 
may need more RAM. 

• Physical Memory: The amount of RAM installed in your Mac.  
• Memory Used: The total amount of memory currently used by all apps and 

macOS processes. 
! App Memory: The total amount of memory currently used by apps and their 

processes. 
! Wired Memory: Memory that can’t be compressed or paged out (moved) to 

your startup drive, so it must stay in RAM. Wired memory used by a process 
can’t be borrowed by other processes. The app's programmer determines 
how much wired memory must be used.  

! Compressed: The amount of memory in RAM that is compressed to make 
more RAM memory available to other processes.  

• Swap Used: The space used on your startup drive by macOS memory 
management. It's normal to see some activity here. As long as memory 
pressure is not in the red state, macOS has memory resources available. 

• Cached Files: Memory that was recently used by apps and is now available for 
use by other apps. If you've been using an app and then quit using it, the RAM 
that it was using then becomes available to other apps. If you open the app 
again before its cached-files memory is used (overwritten) by another app, it 
opens more quickly.  

Energy Pane 
The Energy pane shows overall energy use and the energy used by each app. (See 
the illustration on the next page.) 

The Energy pane can be especially pertinent and useful for Mac portable computers 
because it shows how much battery your apps are using. This can help you make 
sure you’re getting as much life out of your Mac portable as possible. The more 
energy your computer uses, the lower battery life you’ll get.  
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Energy Pane (Credit: Mac Activity Help) 
Display. As shown in the illustration above, the Energy pane displays five columns 
(excluding Process Name and User): Energy Impact, Avg Energy Impact, App Nap, 
Requires High Perf GPU (only available for portable computers), and Preventing 
Sleep. All of them can be particularly useful for portable computer users to help 
maximize battery life.  
• Energy Impact: A relative measure of the app’s current energy consumption. 

Lower numbers are better. A triangle to the left of an app's name means that 
the app consists of multiple processes. Click the triangle to see details about 
each process. 

• Avg Energy Impact: The average energy impact for the past 8 hours or since the 
Mac started up, whichever is shorter. Average energy impact is also shown for 
apps that were running during that time, but have since been quit. The names 
of those apps are dimmed. 

• App Nap: Apps that support App Nap consume very little energy when they are 
open but not being used. For example, an app might nap when it's hidden 
behind other windows, or when it's open in a space that you aren't currently 
viewing.  
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• Requires High Perf GPU: If your portable computer has the high-performance 
GPU (graphics processing unit), such as a Radeon GPU, and the app that you’re 
using requires it, then the indicator in this column will be yes. Such a GPU can 
place a high demand on your battery, reducing battery life.  

• Preventing Sleep: As noted previously, this indicates whether the app is 
preventing your Mac from going to sleep. 

Summary Information. More information is available at the bottom of the Energy 
pane:  

 
Energy Pane (Summary Information) (Credit: Apple Support – Use Activity Monitor on your Mac) 
• Energy Impact: A relative measure of the total energy used by all apps. The graph 

moves from right to left and updates at the intervals set in View > Update 
Frequency.  

The remaining items are also displayed on Mac portable computers: 
• Graphics Card: The type of graphics card currently used. As noted previously, high–

performance cards use more energy.  
! Macs that support a feature known as “automatic graphics switching” save 

power by using integrated graphics. They switch to a higher-performance 
graphics chip only when an app needs it.  

! “Integrated” means your Mac is currently using integrated graphics. “High Perf.” 
means your Mac is currently using high-performance graphics.  

! To identify apps that are using high-performance graphics, look for apps that 
show "Yes" in the Requires High Perf GPU column. 

• Remaining Charge: The percentage of charge remaining on the battery. 
• Time Until Full: The amount of time your Mac must be plugged into an AC power 

outlet to become fully charged. 
• Time on AC: The time elapsed since your Mac was plugged into an AC power outlet. 
• Time Remaining: The estimated amount of battery time remaining on your Mac. 

(Before macOS Sierra, this information was available from the Battery menu bar 
item.) 

• Time on Battery: The time elapsed since your Mac was unplugged from AC power. 
• Battery (Last 12 hours): The battery charge level of your Mac over the last 12 

hours. The color green shows times when the Mac was getting power from a power 
adapter. 
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Next Presentation 
Next month, we’ll finish in Part 2 the review of Activity Monitor by discussing the 
Disk and Network functions, some additional information, and how to use this app 
to troubleshoot performance problems. 

If you have any suggestions for presentation topics, please contact me at 
slp4668@gmail.com.  

—Steve Parker 


